J-Body Automobiles Forum banner
1 - 17 of 17 Posts

·
Banned
Joined
·
4,055 Posts
Discussion Starter · #1 ·
Well, before I even start typing something about whats wrong with my engine. I can't do the 3400 swap guys as much as I really would love to. I'm a poverty College student :lol: Anyways...I went to school today and the car seemed to be running fine...but once i got into TO ( where my school is) the car started to run hot, So i turned the fan on ( I did the fan override switch for that reason) and finally got parked and all. Now coming home! This was a different story the car seemed to have NO power what so ever! and drank a Crap load of fuel!:eek: There is no knocking noises or anything like that in the engine. I just changed the oil and filter, Spark plugs and wires are new.
Any help would be awsome! Shes my daily driver so kinda need to keep it running good. :-?
Car specs
1994 Cavalier
2.2 L
5 Speed manual
 

·
Registered
Joined
·
3,794 Posts
So you have a 2.2L and you overheated it? And now it's running poorly and using a lot of fuel?

Headgasket
They're awfull about blowing headgaskets with just a little extra heat. I know from experience. My first cavalier had that problem. I went through about 3 gaskets. I also work in a machine shop and I have to pressure check atleast one a day. 80% of them crack on the exhaust side of the head. So make sure to get it pressure checked and resurfaced.

Good luck with it.

-Joseph
 

·
Banned
Joined
·
4,055 Posts
Discussion Starter · #3 ·
I didn't over heat it...it was running hotter than normal tho...its usually on the first line so like 50 something like that and it was half way between that line and the line above that lol...sorry for the noob statement but really i don't know what the increments are for the temp....but I will for sure check the head gasket. thanks.
 

·
Banned
Joined
·
4,055 Posts
Discussion Starter · #5 ·
the Check engine light didn't come on :-?
Antifreeze is perfect used the tester tis where its should be.
Head Gaskets ok, there is no leaking oil or anything,
No crack in the head.....
ahhhhh its a FUBAR mystery :eek: :lol:
 

·
Banned
Joined
·
4,055 Posts
Discussion Starter · #6 ·
ummm just talking outta my a$$ but is it a possibility that my exhaust system is completely F*** right over? like the cats screwed and so is the muffler?
 

·
Registered
Joined
·
6,529 Posts
cavi_rs_94 said:
the Check engine light didn't come on :-?
Antifreeze is perfect used the tester tis where its should be.
Head Gaskets ok, there is no leaking oil or anything,
No crack in the head.....
ahhhhh its a FUBAR mystery :eek: :lol:
I didn't mean the mixture, I meant the level. what tester did you use?
 

·
Banned
Joined
·
4,055 Posts
Discussion Starter · #10 ·
umm the Normal Anti-freeze and coolant tester? didn't know there was more than one kind..... :eek:
and the levels good its where it should be
 

·
Registered
Joined
·
6,529 Posts
cavi_rs_94 said:
umm the Normal Anti-freeze and coolant tester? didn't know there was more than one kind..... :eek:
and the levels good its where it should be
Sigh...

I meant levels.. as in.. is it dropping day to day? that's one sure sign of a coolant leak/head gasket.

I would think if the car was running this poorly..... next morning, start the car, and, well, smell the tailpipe.. wait a bit then smell again.. Does it smell like antifreeze? A REAL LOT of steam?
 

·
Banned
Joined
·
4,055 Posts
Discussion Starter · #12 ·
well the levels don't change day to day, heres what I did this morning. Started the car, looked at the tail pipe and there was no abnormal steem / smell, let it run for 10 mins than turned it off for a few mins, than did that again and there was nothing out of the norm......
 

·
Registered
Joined
·
467 Posts
I don't think that the waterpump would change the fuel econmoy of the car, but it would explain the over heating, and no smell of coolant.
If the pump is really screwed over, I think that it may be possible for it to affect your milage.

Just thinkin out loud.
 

·
Banned
Joined
·
4,055 Posts
Discussion Starter · #17 ·
well i have got a new CAT so im gonna put that on see where that gets me nice idea dave make it straight pipe :eek: :lol:............im for sure gonna check the water pump....is it possible that their is crap in the water pump cause it only acted up that once I've been watching it........and fuel filter might be that too.....its probably the original one from 1994 :eek: the guy i bought it off didn't really care about it to much :( oh and one other thing the guy at the store said their is difference's in the CATS.... I personally never heard of a difference other than universal and direct fit.....but I could be wrong is there a difference????......but he seemed pretty stupid i got him to look up piston return springs for a 1969 rolls-cinardy.....10 mins later he said they didn't have any instock :eek: :lol: so that might have just answered my question.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top