J-Body Automobiles Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
4,510 Posts
Discussion Starter · #1 ·
Somebody just take the car, burn it sell it part it whatever i dont want to touch it right now.

20 fucking days til the bash, eveyrthing is going GREAT! 3400 is running good (thanx dave even tho it might not matter now.....) car is looking great. Wont start. ok, so it took me like an hour and figured out that ECM fuse was blown. no clue why. whatever, easy fix. going home to my friends house for the night, clunk clunk clunk. wtf? We stop, sounds liek a CV is going out. stop, wiggled them a bit, hmm, nothing too out of the ordinary. Pull out of the gas station we stopped at, go left into the center lane...... FUCKING KABAM!!!!! wheel bounces off towards the curb, rotor gouges a chunk form the pavement and i'm stuck,,,,,,,, Apparently, WHOEVER tightened those lugs(no blame yet b/c i forget who did it) didnt get them tight ENOUGH, so i snapped off 4 of the studs(because i only had 4 lug nuts on). fender and GFX ar fux0red.
this half-drunk guy goes 2 blocks to his house and gets a jack(none in my car, just got it going again so stuff form the int is scattered), we jack it up, put the wheel on with one stud/lug nut, and it actually held, thank fucking god, so we were able to push it over to the curb and be legally parked for the night. oh and it's leaking some oil-like fluid, too, after hitting the ground. *prays for cracked oil pan* i fucking hope it's not the tranny..... if it is then i wont be driving this car to the bash more than likely....

Anyway here i am at my friends house writing this post. i dont even know what i'm gonna do right now. the car is sitting in the fucking ghetto of downtown davenport, cant be driven b/c it's leaking an unknown fluid and has 1 fucking lug-nut.

oh and i just got the insurance and plates put on this car this morning, and my license back this morning, too. Great fucking day. Thw ONLY thing i'm glad for is that the thing didnt fly off when we were on the highway..... even though that might have made my life a lot easier by ending it.


Dave if you see this call me asap, unless you're busy. Dont care what time.........
 

Attachments

·
Premium Member
Joined
·
10,540 Posts
That sucks Damon, just calm down. maybe you'll be able to hit the yard to get some of the parts you need. Wish you the best of luck.

I know how it is a few years back my z got painted, got it back at the end of sept. someone broke into it on my bday oct 2nd. we lowered it, took it for an alignment the morning of oct 9th, the afternoon of the 9th it went to have a viper alarm installed. they call me up tell me the car is done. up at the counter paying for the alarm i see my car coming out then i watched it smash into the back of a van.
 

·
Registered
Joined
·
1,885 Posts
aww geez, that suck ass!! that reminds me of all the probs i had with my buick. i went thru 2 seized engines before it actually ran right. both times the POS external oil pump and new timing cover(s) failed. for almost 3 years i only put 1 mile on the car. i was running the non-intercooled top end at the time and i just got done installing an intercooler. a ford 7.3 powerstroke intercooler to be exact. the bad part was it the TB was on the side of the turbo, so there was ALOT of delay in throttle response due to about 10 feet of intercooler piping. one day i was trying to get the car loaded up on the trailer to get a new DP made at the shop. the trailer was a heavy equipment trailer so it didnt have a gradual enough incline on the ramps. the car made it halfway up the ramps before it got hung up on the catylitic converter. so i cut the wheel slightly and put it in reverse. the delay in the throttle caused the car to keep pulling. so it hit the brakes hard to try and stop. and furthermore i was having trouble keeping rear brakes operational due to the wheel cylinder kept coming loose. so i had no rear brakes at the time. so anyway, the car kept pulling after i let off the throttle and i locked up the front brakes. the car slid off the ramps and landed on its nose. the intercooler i just spent the whole weekend installing, came thru the header panel and busted the whole assembly off comepletely. after that the car was deemed "the bad luck buick :lol: " it wasnt until last year that everything started to come together and then the tranny burned up :evil: so another summer went by until it was finally on the road in mid october '06. my whole point to this novel is that things will come together....eventually. and there is alot of people here on V6Z24 that will help out as much as possible. hell, bring it to the bash, someone might have a fender for ya.
 

·
Registered
Joined
·
4,510 Posts
Discussion Starter · #4 ·
haha, yeha i know, people here are really great about helping each other out, i love it here.....

oh and BTW it's parked in the same city the bash is in :lol: My friend is getting me a price on a whole new wheel bearing(it needed it anyway) b/c he gets them basically at-price through the place he works.

I'm really more worried about that leak..... if it's the oil pan i dont care, i have 1 i can use, and i can fill it with oil and get it to somewhere to work on it, the leak is slow enough.... if it's the tranny i can drive it too i guess, but i cant afford a new tranny right now....
 

·
Registered
Joined
·
6,269 Posts
v6bluebird said:
haha, yeha i know, people here are really great about helping each other out, i love it here.....

oh and BTW it's parked in the same city the bash is in :lol: My friend is getting me a price on a whole new wheel bearing(it needed it anyway) b/c he gets them basically at-price through the place he works.

I'm really more worried about that leak..... if it's the oil pan i dont care, i have 1 i can use, and i can fill it with oil and get it to somewhere to work on it, the leak is slow enough.... if it's the tranny i can drive it too i guess, but i cant afford a new tranny right now....
im gonna go with the oil pan, as the 3400 hang down below the subframe no?? and it was the passenger side wheel, trans is on the driverside, my moneys on the oil pan, shity deals tho, i almost had the same problem, someone loosened all the wheels on my car, i caught it before one flew off tho
 

·
Premium Member
Joined
·
4,261 Posts
Damnit, that sucks ass man. :( Let me know if you need anything Damon, I have a few extra parts laying around. I'm sure Dave will have you covered though since he could build another J out of all the parts in his shed. :lol:
 

·
Registered
Joined
·
1,953 Posts
Jeezzzz bro.......like you said, thank the good lord you wasn't travelin down the highway. That sucks man, if you need anything I might have some stuff hangin around, but like they said.....Dave has everything!!!!!lol
 

·
Registered
Joined
·
4,320 Posts
Damn dude, Im sorry. I know how ya feel...there were times when I just wanted to push my bird into traffic or try to roll it...hang in there...I miss the bird, now...like I said before, I'd be there at hte bash if I still had the bird...
 

·
Registered
Joined
·
4,510 Posts
Discussion Starter · #12 ·
Well, it's fixed. i drove it home earlier and chopped the section of wheel well that's rubbing, so it's driveable now.... just gotta get a new fender, wheel well liner, and fix the GFX now :D :D :D
 

·
Registered
Joined
·
1,330 Posts
I as well can relate dude don't kno how many times i threatened to push my old Z out of the garage and burn it on the spot! Like the time i had just finished puttin the whole thing togather backed it out running great went to drive away (on my way for safety inspection) and the fuel pump quit dam i was mad lol! Main thing is yur ok and yur car is on it's way to being fixed good luck man!! :)
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top