J-Body Automobiles Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have a 1989 Z24 with a code 43
If my timing is not retarted during driving,and my advance is normal,but I have a code..is the retarted happening when the code is set? And then it goes back to normal? Because I’m trouble shooting this problem..I have read a lot of forums saying it’s wiring at the esp,and knock sensor?
 

·
Registered
Joined
·
11 Posts
CODE 43
Trouble Code 43 indicates that there may be a malfunction in the Electronic Spark Control (ESC) circuit. ESC is used to sense spark knock (pinging) and retard the timing to eliminate it. The knock sensor is located at the rear of the engine block. The ECM will retard the timing by as much as 20 degrees in 1 degree increments. A loss of knock sensor signal or loss of ground at the ESC module will cause the signal at the ECM to remain high. The ECM will act as if no knock is present, and may possibly result in engine damage, due to detonation.
Code 43 is set when:
    • Voltage at Knock Sensor is above 4.8 volts or below .64 volts.
    • Either condition is met for about 10 seconds.
Possible causes:
1) Open or shorted knock sensor
2) Loose knock sensor
3) Excessive mechanical noise within engine
4) Improper or incorrectly installed MEM-CAL in the ECM or defective ECM
5) Intermittent open in the EST line to the ignition module
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
Ok so I understand how this code is set,thanks for the information,my car has a rough idle on cold start,and sometimes at hot idle..don’t know if it’s related to knock..but I noticed when I drove it from work to the store,shut dow go to restart then it hesitates and sometimes dies,then restarting ok,so I’m not sure we’re to start,now if my voltage at the ecm is 5v with koeo is that acceptable? And if it was a faulty knock I would have retarted timing all the time?because my scan tool shows no retarted timing…but not sure it’s retarted while acting up!!
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
CODE 43
Trouble Code 43 indicates that there may be a malfunction in the Electronic Spark Control (ESC) circuit. ESC is used to sense spark knock (pinging) and retard the timing to eliminate it. The knock sensor is located at the rear of the engine block. The ECM will retard the timing by as much as 20 degrees in 1 degree increments. A loss of knock sensor signal or loss of ground at the ESC module will cause the signal at the ECM to remain high. The ECM will act as if no knock is present, and may possibly result in engine damage, due to detonation.
Code 43 is set when:
    • Voltage at Knock Sensor is above 4.8 volts or below .64 volts.
    • Either condition is met for about 10 seconds.
Possible causes:
1) Open or shorted knock sensor
2) Loose knock sensor
3) Excessive mechanical noise within engine
4) Improper or incorrectly installed MEM-CAL in the ECM or defective ECM
5) Intermittent open in the EST line to the ignition module
Ok I used my scantool and finally seen the timing retarted 30% when engine at idle and driven for a hour..the idle was hunting..SURGING…so I cant check the voltage at the ecm wiring while it’s running bad because I’m on the freeway..so any suggestions?I would think if it was the knock sensor was bad it would cause retard timing the whole time I’m driving cold or hot?? Correct?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #7 ·
Replace the knock sensor. It's like 30 bucks. Check the plug, wiring, ground. I had a similar problem, it turned out to be in the 32 pin connector for the ecm.
THANKS SO MUCH FOR YOUR HELP..i will test it at home..I think mine could be intermittent because it seems to happen when it’s the engine is warm..but to be honest,I haven’t tried checking first thing in the morning..I tried removing the ecm fuse but it won’t clear…it only seems to clear the code when I remove the battery ground..and my ecm gets really hot ..don’t know if this is normal? Let me know what you think??
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #14 ·
Ok after checking my voltage at my ecm BLUE knock sensor wire I have 4.5 volts,so then I tested the sensor itself found the ohm was 0 ..then I removed the sensor and bench tested it finding that the tape tested absolutely nothing… sir looks like it’s trashed,, I will get back after I install it tomorrow,and give a update!! Once again thanks a million!!!
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #15 ·
ok big problem.. now after installing new knock sensor it runs bad..so I checked the scan tool,this was after I cleared the code,it ran fine,then I was doing a idle relearn,idle in drive for 10 minutes,then the timing starts to retard the whole time..before I replaced the knock sensor,it never ran bad or retard,just every so often..now it’s all the time… I’m getting my 4.5 volts on the k/s circuit..I can’t figure out this one???
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #16 ·
ok big problem.. now after installing new knock sensor it runs bad..so I checked the scan tool,this was after I cleared the code,it ran fine,then I was doing a idle relearn,idle in drive for 10 minutes,then the timing starts to retard the whole time..before I replaced the knock sensor,it never ran bad or retard,just every so often..now it’s all the time… I’m getting my 4.5 volts on the k/s circuit..I can’t figure out this one???
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #19 ·
I’m not to sure I need this forum.. I understand that this is free .. I’m happy that you have tried to help me with the repair guide.. much appreciated.. I’m sure in your own way your not really qualified to help… I’m also picking up some sarcasm??? At any rate I don’t plan on selling it for parts .. IF THERE IS ANYONE WITH ANY OF THE SAME PROBLEM PLEASE FEEL FREE TO ADD SOME EXPERIENCE COMMENTS… THANKS!!!
 

·
Premium Member
1988 Z24 Coupe 5spd, 1988 Wagon w/94 Auto Drivetrain, 1992 Z24 Convertible Auto, 1994 Z24 Coupe 5spd
Joined
·
2,650 Posts
Did you check the resistance of the new sensor before you installed it?
 
1 - 20 of 21 Posts
Top