J-Body Automobiles Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
the clutches on these 93 z-24's are pretty fancy considering i had to pay $700 bucks to replace it, i guess becuase its a hydraulic clutch.

anyways i changed that but for some reason it doesnt seem like theres enough pressure becuase i have to slam it into first, second, and reverse, maybe the master cylinder? i need help fast, its driving me insane.
 

·
Super Moderator
Joined
·
7,650 Posts
$700!
you got raped on labor then. You can get a nice aftermarket clutch for a couple hundred.

If it isnt working right, i would take it back to the shop that installed it?
 
G

·
Discussion Starter · #3 ·
thats 700 canadian with taxes, and ya that still is pretty bad, im starting to think it has something to do with the tranny, so im just gonna throw in a full racing transmission, im sure thats what the problem is, ill let you know how it goes
 

·
Registered
Joined
·
5 Posts
I just fixed that problem on my 89 Z24. It turns out that the slave cylinder and the master cylinder was bad on mine. I had to replace both and then bleed the system. Now it works good as new. My dad and I did it all by ourselves.
 

·
Registered
Joined
·
121 Posts
im not sure if im right but it could be your syncro's...if you pound the crap out of your car for a while then the next time you try to shift slow and easily it's gets hard to get out of gear...i have the same problem with mine but only after im driving fast and shifting hard....try to push the clutch a few times and see if its easier
jimmy
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top