J-Body Automobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
468 Posts
Discussion Starter · #1 ·
Lately I've noticed my car isn't running like it used to. The engine sounds different and it seems to run rough. The other day I got a check engine light on the way home from work, and of course it went out 2 minutes before I was home. I checked for codes and got a code 32 (EGR). The engine seems to be making more ticking noise now that sounds like it's from the valvetrain, and the exhaust makes a spitting sound when I let off the throttle.

You can hear the exhaust sound best in the second half the the second video when I moved the camera farther away.

[/URL]

[/URL]
 

·
Premium Member
Joined
·
7,448 Posts
sorry, either the camera cant pick up the noise, or its not what you think it is, but to me it sounds like normal valvetrain noise..

oil level topped up?
 

·
Registered
Joined
·
468 Posts
Discussion Starter · #5 ·
Well I took off the EGR valve and it was a bit dirty but otherwise ok. All 3 of the pintles were closed. Unplugging the connector running made no difference. What's the best way to clean the EGR, carb cleaner? I'm thinking of buying an ALDL cable so I can get an idea of what's really going on. Part of me hopes that this engine dies so that I have an excuse to swap in a 3400, but the other half doesn't want to spend the $1000+ that the swap will likely cost.
 

·
Registered
Joined
·
1,674 Posts
That cracking sound when you rev the engine is an exhaust issue, sometimes the fins let go in the mufflers this can happen or if something is about to rot out or a bad spring kit up front on the downpipe. Since you've mentioned the ruff Idle I would clean the TB, IAC and that EGR too. You should also unplug the battery for a good bit and do an idle relearn, maybe the O2 sensor and check for vac leaks. But from the vids it just sounds like an old stock 660.
 

·
Registered
Joined
·
468 Posts
Discussion Starter · #9 ·
I've already done the idle relean when I disconnected the battery to change the OPSU. It could very well be the muffler since the one on it right now is most likely the original one. The O2 can probably also be replaced to because it's old. I've been wanting to buy a Magnaflow anyways so now I have an excuse. :lol: I'm also going to buy some gaskets and take apart the TB, EGR and IAC. I think I'll also get one for the front valve cover and take it off to see what the valvetrain looks like. Thanks for the suggestions so far guys!

Also, would an increase in fuel economy be an indicator of a problem? I used to get around 20mpg, and this summer I've been getting 25-28.5 mpg, and that's even with the occassional WOT. The only thing I've changed is the fuel pump and filter. Maybe it's just because of warmer temperatures and different seasonal gas formulas?
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top