J-Body Automobiles Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
1,110 Posts
Discussion Starter · #1 ·
I just put your custom intake on my 89 Z and it works great. the only thing is that after a while, as the engine compartment heats up, the end of the filter with the clamp gets soft and the clamp slides off. the clamp is as tight as it will go and when it's at a cool temp and there's no way to rip the filter off so i know it's tight. It's when it gets hot that the clamp slides off. increasing the diameter of the pipe with a piece of rubber is what you said to Z24dogg and i'm gonna try that but how bout using some heat shielding under the filter?? could that lower the temp enough to keep the clamp on??
 

·
Registered
Joined
·
221 Posts
If anything, the heat shielding should go behind the filter as much as possible, if that's the route you're going. Putting it underneath would somewhat inhibit the cooler air flow, but by putting it more behind it, you can put it more between the filter and the block. Also, wrapping the large radiator hose that sits under the stock airbox bracket couldn't hurt.

_________________
Objects in mirror are imports.

[ This Message was edited by: antipode on 2001-08-09 12:59 ]
 

·
Registered
Joined
·
221 Posts
I'm not sure why yours would do that. Mine fits snugly up against the frame, so I guess that would prevent any slipping. Depending on what model filter you have, you may or may not experience this problem. I'm sure just enlarging the pipe with duct tape would work fine, but heatshielding can't hurt, either.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top