J-Body Automobiles Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
703 Posts
Discussion Starter · #1 ·
Here is a shot of the goods. Here is a little overview of what Iv'e done: Obviously put in a 3100, converted it to a 5spd, changed to a 90 5spd ecm,
rewired the egr valve at the ecm. Here is the problem I'm having, It idles fine, runs fine while driving but when I come to a stop it idles down real low and will shut off or almost shut off. I got a code 45) rich exhaust, now I didn't swap the 2.8 injectors into the 3100 do you think that is the first thing I should try or should I look at something else before I start ripping the plenum back off. Any help would be appreciated,

Thanks Jason
 

Attachments

·
Registered
Joined
·
439 Posts
Sounds like your egr is sticking open, or binding up. If it stayed open completely, you would stall when returning to idle speed, but if you said it sputters and *sometimes* dies, I would disconnect the egr to see if that stops it. If it does, you could try cleaning it (if you have the electronic egr). If you have the vacuum egr, I guess you could disconnect the vac line, plug it, and test it that way. The 88 I had was egrless... It kept buggereing up so I yanked it...
 

·
Premium Member
Joined
·
17,284 Posts
What type of tuning have you done? Any??

This happens to my car (and Moon's) everytime we unplug the battery, it takes a few days of driving around for the car to remember how to idle without quitting on us....

Brad
 

·
Registered
Joined
·
703 Posts
Discussion Starter · #5 ·
No tuning, don't have any equipment nor do I know how to do any tuning. But I have been having problems with my battery not staying charged, I think I'll go get a new one and see if that helps. Mine is getting pretty old and has been siting almost a year not being charged. So I'd say it's time for a new one. I'll let ya know if this helps.

Is there any tuning that would be necessary for it to run better? If so would anyone around eastern PA be able to help me out with some tuning?
 

·
Administrator
Joined
·
25,608 Posts
it should run ok on the 3.1 tuning as long as you have the 3100 injectors installed and the stock FPR for that engine.

If you want to get max power out of it you will need someone to tune it for you, there is a sticky in the general J section that covers the basics of tuning.
 

·
Registered
Joined
·
703 Posts
Discussion Starter · #7 ·
another prblem i'm having is the brakes are supper soft. do I have a vaccum leak that is possibly causing both these problems? or is my brake problem to the fact I didn't change to a manual brake booster and master cylinder or wouldn't that matter? This is really frustrating, I get the car driveable but yet I can't drive it because of these two problems. please help, I don't want my Z to be sitting around collecting dust anymore.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top