J-Body Automobiles Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Yesterday i was driving home from school and i decided, since i was on a back road, that i would see just how fast my '90 Z24 woulod go.(this was stupid i know).... but right when i hit 120 the engine jumped back down to 100 and it was loud pop. so is there a governor on these cars or did i jus redline it.

thanx
 

·
Super Moderator
Joined
·
7,650 Posts
Yes, there is a speed limiter on our cars. Depending on the year, it is between 112 and 120 or so. There are a couple ways around this. The easiest is getting a custom chip, although you can bypass it with a switch and some splicing of wires...
 

·
Registered
Joined
·
221 Posts
Ah, I remember the first day I learned that these cars have a limiter. Scared the hell out of me, since I lurched in the middle of the night in the left lane of the highway, guard rail smiling at me. Close.
 

·
Registered
Joined
·
129 Posts
lol u guys are lucky.. when i had my new clutch put in the stupid mechanic forgot to screw the speedo cable back in.. i was cruising down the highway and jee... im goin the speed limit and im passing all these guys.. kewl.. maybe the mechanic fixed something so i floored it. well fuck me... all of a sudden im at 200+ im like woah kewl.. then... danger reveled itself.. my 200+ kmph went to -10kmph. i literaly near puked.. i thought i busted my entire car cause when it did that it sort of died down all of a sudden.. so i turn on the the nearest offramp and ended up in a mall parking lot screaming at myself and cussing the living shit out of the car.. then i poped the hood and tried to see what i did... and then i saw it.. a cable just swinging in the breeze.. wonder what that does.. so i looked for what it could attach to.. and theres a screw hole sitting about 5 inches away.. screw'd it inn and started the car... boom.. everything was fine.. SON OF A BITCH!! then i drove home and called the mechanic up and bitched at him.. i got a free oil change and filter, and $50 off anything in the shop.. hmm.. still think i should have gutted him...
 

·
Registered
Joined
·
221 Posts
At least you got a deal out of that. All I did was learn what happens. No, I didn't... I did it again, I kept it at 120 for like 2 miles before it kicked my ass, no more than a week later.

By the way, you seem very emotional.
 

·
Registered
Joined
·
1,511 Posts
I put a JET performance chip in my car and did not loose the governor. My '93 Z still shuts off at 110. Moon, what do I need to do with the wiring, like you suggested earlier???
 

·
Super Moderator
Joined
·
7,650 Posts
You need to cut one of the wires running to the VSS (Vehical Speed Sensor) on the tranny, and put a switch in, so you can open and close the connection. When the connection is broken, the speedo will fall to 0 (tach should keep reading) and you should be able to keep accelerating. I have NOT tried this, but it is on my list of things to do, so I will post a how-to if I get around to doing it

Oh, and that I why I don't recommend JETT chips
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top