J-Body Automobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
385 Posts
Discussion Starter · #1 ·
Ok on my Digital Dash whenever my headlights are on I can dim the backlighting, I don't know if that's the same on Analog or not. But anyways All of a sudden Whenever I turn on my lights my duages go completly black and I can't dim them. I checked the fuses and it's not that. Anyone have any ideas why this is happening?
 

·
Registered
Joined
·
918 Posts
Make sure you don't have the guages dimmed completely out, when you turn on the headlights! Make sure the knob for the dashlights is up! I made the mistake of thinking there was something wrong when mine did the same thing, turned out to be I had forgotten to turn the knob back up! :lol:
 

·
Registered
Joined
·
837 Posts
i'd guess you're having the same problem i was/am.

FIRST: check ALL fuses, make sure they are not blown

if all fuses check out ok, you'll probably have to go searching around under the dash on the driver's side. remove the first panel, then the piece right below the steering column.

directly to the right of the fuse box is an assembly of various electrical components. remove that assembly by removing the two little screws/bolts on the side of it. pull it down, then find this thing:


jumper the two thin prongs sticking up with the headlights on and see if that makes the dash lights work. if it does, there's your problem. i'm not quite sure what that is, i just discovered that part a couple days ago and haven't had time to figure anything out.
 

·
Registered
Joined
·
3,967 Posts
wehrengod said:
i'd guess you're having the same problem i was/am.

FIRST: check ALL fuses, make sure they are not blown

if all fuses check out ok, you'll probably have to go searching around under the dash on the driver's side. remove the first panel, then the piece right below the steering column.

directly to the right of the fuse box is an assembly of various electrical components. remove that assembly by removing the two little screws/bolts on the side of it. pull it down, then find this thing:


jumper the two thin prongs sticking up with the headlights on and see if that makes the dash lights work. if it does, there's your problem. i'm not quite sure what that is, i just discovered that part a couple days ago and haven't had time to figure anything out.
Part number #1995263 :D
 

·
Registered
Joined
·
837 Posts
nice, gino lol.

i knew to check it because i traced the rest of the damn wiring through my dash/fusebox, and that was the only thing that didn't work. stupid part.

anyway, it was so exciting when my dash actually lit up for the first time since i've owned the car :pimp:
 

·
Registered
Joined
·
38 Posts
man you are a life saver. that was what was wrong with my car. This is the first time in overa yr that I haev a dash when I turn my lights on. THANKS.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top