J-Body Automobiles Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
10,487 Posts
Discussion Starter · #1 ·
i thought jbp made custom solid mounts? i cant find any polyurethane or solid ones on the site. every mount in my car is brand new and they are all already shot! i cant believe it. i mean brand new as in less than a year old, and they are already gone?! what kind of BS is that.
 

·
Registered
Joined
·
10,487 Posts
Discussion Starter · #4 ·
that is exceptionally gay. what about polyurethane? im serious, i cant be going through motor mounts like this...its gonna kill my transmission again.
 

·
Registered
Joined
·
10,487 Posts
Discussion Starter · #6 ·
thats cause we dont even have stoppers in ours. in normal cars when the mount goes bad tehre is a metal bar or something to keep the motor from going all over the place. we just have some shitty rubber encased in a piece of metal.
 

·
Super Moderator
Joined
·
20,045 Posts
ninteyonez24 said:
thats cause we dont even have stoppers in ours. in normal cars when the mount goes bad tehre is a metal bar or something to keep the motor from going all over the place. we just have some shitty rubber encased in a piece of metal.
Show me a car like that. :roll:
 

·
Super Moderator
Joined
·
20,045 Posts
ninteyonez24 said:
ask jeff, my boss.
Please, let all the details out, I have yet to see anything different about engine mounts in other vehicles from that in the J-body other than fitment differences, as far as holding the engine in place they do a great job of that, there is no "design flaw" there.

Maybe, just maybe, have you thought that things might be misaligned? There is adjustment to all of teh engine mounts in these cars and that needs to be set correctly to have long engine mount life. :roll:
 

·
Registered
Joined
·
10,487 Posts
Discussion Starter · #11 ·
maybe, just maybe, could you tell me how to adjust these adjustments so i can increase my engine mount life, almighty raven?
 

·
Registered
Joined
·
10,487 Posts
Discussion Starter · #13 ·
good i would prefer the poly's over teh solid just cause im not making that kind of power. what section are they under man?
 

·
Registered
Joined
·
5,302 Posts
Alll my mounts are fried! :evil: The dealer only replaced one front mount and I think that killed the other ones. :guns: :guns: I think jbodyperforance has em but I dont see em under suspension :-?

Hey mev for a full set of mounts if thats available? I mean motor mounts, tranny mounts and doggy bones . Everything.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top