J-Body Automobiles Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter · #1 ·
hey guys....i just put a AEM short ram cold air intake on my 96 z24.....it added alot of poneys and the throttle response is great now.....but what i was wondering is when i hammer the gas a werid sound comes out of the filter.....the intake is a AEM body with a K&N cone air filter...it sounds like a honda civics exahst but its coming from the filter area cause there is no difference in the exahst sound on my car so i know its coming from the filter....if anyone knows about this please let me know cause its bugging me not to know if this is normal...if its not normal please let me know whats wrong...and what i did wrong putting it in my car or anything you can tell me would be very much appreciated
thanks
jimmy
 

·
Registered
Joined
·
415 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter · #4 ·
thanks guys i thought it was that but i wasnt sure and it was bothering me a bit not to know.......but i am really glad with this new intake and i would sugest it to anyone who is thinking about it...alot more power and beautiful throttle response
jimmy
 

·
Registered
Joined
·
434 Posts
Everytime i start my 3.1 with intake it makes a SSSSHHHHHH sound for about 15 mitnues until the car is warm.. And persanly i love it..

couple pics..

<LINK_TEXT text="http://members.home.net/rebootcomputers ... engine.jpg">http://members.home.net/rebootcomputers/new%20paint%20engine.jpg</LINK_TEXT></URL>">

http://members.home.net/julu6/10-6-2001/Dcp00352.jpg</URL>">
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top