J-Body Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6,269 Posts
Discussion Starter · #1 ·
today when i was driving the power locks went nuts and just started clicking and trying to lock and unlock by themselves, i think its the relay under the hood if there is one cause i just washed the car and got some water under the hood, also when u take out the fuse nad put it back in they work for about 3 lock/unlock cycles then start clicking again
 

·
Registered
Joined
·
6,269 Posts
Discussion Starter · #2 ·
also if you could tell me if there is a relay under the hood where is it exactly, come on i need help, i got mad and ripped off the door panel and cut the wires to the solenoid to stop it, have 2 more doors to go if i can't figure out whats wrong
 

·
Registered
Joined
·
2,949 Posts
i have no clue if there is a relay under the hood, but if it is water, just give it a little time and it will dry. then you should be fine :D if its more then that, then i dunno what to say :-?
 

·
Registered
Joined
·
6,269 Posts
Discussion Starter · #5 ·
well its weird, seems to be working now, but i only have power locks on the passenger side of the car now :( . I also have to go and reconnect the wires on the driverside rear lock and the drivers side lock has never worked since i got the car and its no big deal cause its the drivers door anyway, i think i just got water somewhere but its all good now.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top