J-Body Automobiles Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
I have this carzy problem.Ok, first, my car has like no pickup anymore, when i stomp on the gas it doesnt pick up like it used to. it just goes. then, sometimes it will start to spitter,spatter,sputter, and then die in the middle of the road! it almost sounds like something is dropping or something cause its like not wanting to go cause then when it happens and i try to step on the gas it will do it worse. also, if i put it in nuetral and slam the gas it will quit. but right after i put new spark plugs in it started making this weird noise from the back three plugs like someone saying siss repeadetldy.any idea whats going on? could it be a dead cylinder or a bad spark plugs?should i change the spark plug wires cause they are still stck i havent changed them yet. or maybe its because im a little over due on an oil change. any feedback right now would be a miracle because my poor baby z24 is sick and i want to fix her!!
 

·
Super Moderator
Joined
·
7,650 Posts
So there is a hissing sound coming from the right bank? Like air escaping? You didn't cross thread a plug and strip the threads, did you? This started right after you changed the plugs, or you changed the plugs because this was happening? Definately sounds like one of the cylinders isn't firing.
 

·
Registered
Joined
·
202 Posts
Double check where each wire is going you might have crossed one or two of tham causeing the car to run like crap. (does it rev up fine in neutral??)
 

·
Registered
Joined
·
97 Posts
definetly change your wires, get a decent set for like $30. make sure you have all the wires going to the right cylinder, check with the chiltons manual. Change the fuel filter. makesure you have no obstructions in your intake, but i doubt you do though(but you never know, mice). And have a shop inspect your ignition. And maybe even check your fuel injectors.
 

·
Registered
Joined
·
117 Posts
If the car feels like its mis firing then definetly check your coils.. I had that problem.. as for the hissing.. check for vacuum leaks under the hood.. that'd make your car run like shits as well
 

·
Registered
Joined
·
1,576 Posts
Come to think of it, my car always has this nock (its hard to explain) when Im at about 1000RPm, going bout 10km/h, and then step on, and it feels like the clutch just engaged right then, almost like its not engaged completely, and when I hit the accelerator really quick (pedal2metal) it has this nocking sound, so is this normal, or is my clutch going????

Thanks-

John
 
1 - 7 of 7 Posts
Top