J-Body Automobiles Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
When I put my car into drive from neutral, it takes about 2-3 seconds to shift into gear...Tranny fluid is clean and full, and even put some of that Slick50 tranny treatment in about a month ago...but it says it can take up to 100 miles b4 you notice any difference in shifting. Has anyone else used this? Otherwise I'm probably going to need a new tranny, huh?
 

·
Registered
Joined
·
59 Posts
Hey I'm not an expert but i think it would help if you describe your situation a little more. When you say you put the tranny in gear from neutral is this at a stand still, rolling (forward or reverse), and are you applying gas right away (Like to race or have a cool burnout)? If you answer some of these questions it will help us assess the situation and maybe someone else could also shed some light if you are a little more descriptive. Thanks, and have fun cruising.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Both from a stop- like when I'm un-parking and if I push the gas to go it just sits there...and 2-3 seconds later it kicks into gear and goes.
If I shift into neutral down a hill it is the same, 2-3 seconds later it will kick into gear.
 

·
Super Moderator
Joined
·
7,650 Posts
Sounds like your tranny is starting to crap out on you. Probably the valve bodies or something like that, which probably wouldnt require an entire rebuild. Take it to a tranny shop, and they can probably tell you for sure if it is toast or not, and how much it will be to get it back in tip top shape
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top