J-Body Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
First of all my complments on the site Moon...
(my first time here)

Well i finally got my Z24 I have been waiting for (for a long time)

I don't know if anyoine else has had experience with this, but i have an 89 Z24, which i do believe is supposed to have a 2.8L V6 ( correct me if i'm wrong), but mine had a motor change before i bought it, and it has a 3.1L V6, not sure what year 90 or 91, and i find my transmission doesn't seem like it can handle the power from that motor, when crusing on the highway about 110 k's, rpm's are around 4000 to 4500 and if i put it to the floor it jumps right to 6500 to 7000 almost instantly, not sure if this is normal with the Z24's or not since it is my fist one, so if this is normal tell me, if it is not i would really appreciate some input
 

·
Registered
Joined
·
13 Posts
This might sound weird... but do you have the right transmission on there??? Sounds like you might have a tranny from a 2.0l engine!! My 1986 Olds Firenza had a 3spd auto, and revd at about that RPM! And they are interchangeable.
 

·
Super Moderator
Joined
·
7,650 Posts
Uh, that is not normal. And it is not good, since the engine redlines at around 6000.
And 4500 is way, WAY too high for 110km/hr!
Something is definately up with the tranny. Sounds like it is staying in 2nd gear or something.

_________________
Jason Bradwell
Webmaster, V6Z24.com
1992 Cavalier Z24
 
1 - 3 of 3 Posts
Top